タイトル画像

スポンサーサイト

--.--.--(--:--)

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。


テクネクマヤコン


スポンサー広告 トラックバック(-) | コメント(-) | [EDIT]
タイトル画像

WindowsMediaPlayerが重い!解決編

2014.05.02(22:09) 510

昨日の件ですがやっぱ気になったので追求してみました。
プロセスで確認したところ、
WMPを立ち上げた瞬間WindowsDriverFoundationというプロセスがCPU10%くらいに上がりました。

「10%なら大したことないじゃん。昨日は100%付近って言ってただろ?」


ごもっともです。


でも違うんですよ

昨日の100%っていうのは論理コア8個あるうちの一つが100%付近。
上の画像のプロセスでの表示は8個全部まとめたうちの占める割合なのです。

つまり1コア80%なら全体では10%くらい(Corei7の場合)なので妥当な数値ですね。
何百もあるプロセスのうち、一つで10%はやっぱり大きいです

さて、このWindowsDriverFoundationですが実行ファイルはWudfHost.exe
さっそくググってみるとなんか重要なファイルで安易に消すとか絶対だめっぽい。

手動で一時停止する分には大丈夫っぽいですけど。

当初はWMPのライブラリ監視のスキャンとかでつまずいている事を予想していました。
これならライブラリの監視設定ですぐ解決と思ったんですが。

どうも一筋縄でいかないっぽい。


WMPと紐付けされたWWuduHostのトラブルもヒットしないし、これは詰んだか?


しかしテクネさんは諦めない!



WudfHostについて調べてみると、どーーーもUSB関係のなんからしい。
つか説明が難しすぎてこれしかわからない。


とりあえず外付けHDDをWINの安全な取り外しで外して、再現実験をしてみたところ・・・


直った。


というわけで、外付けHDDが原因だったみたいです。

ちなみにこの外付けHDDはELECOMのd2 Quadra USB3.0であります。

このトラブル、
この製品の仕様でそうなっているのか
初期不良なのか
マザボとの相性なのか
私の環境が悪いのか
そもそも他のHDDでもこうなるのか

この辺は全く分かりませんがもしかしたら同じトラブルで悩んでる人もいるかも知れませんので参考までに。

今後ですが、
今のところこの外付けHDD、これ以外はなんのトラブルも無いし3T大容量でまだまだ余ってるのでやっぱ使いたい。
結局WMPに変わる新しいプレーヤーを探す選択になりそうです。
ME☆N☆DO☆I

スポンサーサイト


テクネクマヤコン


<<PS3がHDMIを認識しない件 | ホームへ | WindowsMediaPlayerが重い!>>
コメント
サービスを停止して自動修復しないように設定しました。
USB接続のHDDのデバイスドライバに「!」が付いてますが、何も問題ありません。
Windows8.1
【2015/02/17 05:48】 | #- | [edit]
情報ありがとうございます!
当初自力で解決できず、
HDのメーカーにも問い合わせたのですが原因不明で結局MPCに切り替えました。
そういう解決法があったんですねぇ。

【2015/02/17 21:15】 | テクネ #- | [edit]
このコメントは管理者の承認待ちです
【2017/02/01 18:25】 | # | [edit]
コメントの投稿













管理者にだけ表示を許可する

トラックバック

トラックバック URL
http://techne2.blog102.fc2.com/tb.php/510-a6c99d4a
この記事にトラックバックする(FC2ブログユーザー)
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。